Azure Front Door connectivity issues have prevented users from logging and to visualize log reports and quicklogs in Professional. See more details here: https://azure.status.microsoft/en-us/status There is still some latency in visualizing logs, but the issue is now resolved. We'll keep monitoring this incident. In the meantime, logs can still be saved to PDFs and opened in the file explorer. For the same reasons, Professional also experiences issues with displaying the map.
Posted Oct 29, 2025 - 18:33 UTC
Investigating
Generating log reports and quicklogs in professional is currently problematic. Our team is actively investigating the issue.
Posted Oct 29, 2025 - 17:12 UTC
This incident affected: London (uksouth) (Task Processing, Web API), Australia East (Task Processing, Web API), West Europe (Task Processing, Web API), Canada (Task Processing, Web API), and N.Virginia (eastus) (Task Processing, Web API).