Bentley IMS
Incident Report for OpenGround Cloud
Resolved
This incident has been resolved.
Posted May 24, 2022 - 11:09 UTC
Investigating
Bentley IMS authentication is experiencing an outage. Bentley is investigating the issue
Posted May 24, 2022 - 10:18 UTC
This incident affected: London (uksouth) (Bentley Services).