Bentley Identity Management Service Outage

Incident Report for OpenGround Cloud

Resolved

Bentley has resolved the issues with the Identity Management Service.
Posted Aug 10, 2026 - 15:14 UTC

Update

Bentley has resolved the issues with the Identity Management Service.
Posted Aug 10, 2026 - 15:13 UTC

Investigating

Bentley authentication is experiencing an outage. Bentley is investigating the issue. Refer to the link below for further details.
https://status.bentley.com/incidents/433sgbddgt0l
Posted Aug 10, 2026 - 14:51 UTC
This incident affected: London (uksouth) (Bentley Services), Australia East (Bentley Services), West Europe (Bentley Services), Canada (Bentley Services), and N.Virginia (eastus) (Bentley Services).